Dactyloidae/netwerk
Moonchild c95a802078 Issue #2070 - When multiple HSTS headers are received, only consider the first.
This implements a plain interpretations of RFC 6797, which says to only consider
the first HSTS header.
This slightly conflicts with RFC 7230, which says that sending multiple headers
which can't be merged is illegal (except for a specific whitelist which HSTS isn't in),
so this situation should never occur in the first place (and would therefore not need
the explicit entry in RFC 6797).

It improves HSTS robustness dealing with non-compliant servers.

Resolves #2070
2022-12-30 09:21:48 +08:00
..
base [Network, DOM] Align our implementation with the current CORS/Fetch spec. 2022-11-25 11:41:52 +08:00
build Issue #1829 - Revert "Issue #1751" 2022-05-04 09:40:24 +08:00
cache Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
cache2 Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
cookie [network] Align cookie checks with RFC 6265 (bis) 2022-12-16 11:25:15 +08:00
dns Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
ipc Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
locales Issue #1656 - Part 6: Clean up the build files 2020-09-25 22:04:23 +08:00
mime Issue #1656 - Part 6: Clean up the build files 2020-09-25 22:04:23 +08:00
protocol Issue #2070 - When multiple HSTS headers are received, only consider the first. 2022-12-30 09:21:48 +08:00
sctp Issue #1656 - Part 6: Clean up the build files 2020-09-25 22:04:23 +08:00
socket Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
srtp Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
standalone Issue #1656 - Part 6: Clean up the build files 2020-09-25 22:04:23 +08:00
streamconv Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
system [network] Fix Mac buffer overflow. 2022-11-25 11:43:19 +08:00
test Issue #2070 - When multiple HSTS headers are received, only consider the first. 2022-12-30 09:21:48 +08:00
wifi Issue #80 - reinstated unified building for some large chunks of our code. 2022-09-07 10:36:23 +08:00
moz.build Issue #1656 - Part 6: Clean up the build files 2020-09-25 22:04:23 +08:00
necko-config.h.in import FIREFOX_52_6_0esr_RELEASE from mozilla-esr52 hg repo 2018-01-19 03:59:58 +08:00